2 Wordpress-spørsmål.

En tråd i 'Wordpress' startet av Mr Vest, 14 Nov 2007.

  1. Mr Vest

    Mr Vest Sjefen over alle sjefer!

    Innlegg:
    2.079
    Jeg har sittet en liten evighet og prøvd meg frem for å finne ut hvordan jeg endrer teksten her

    Dette er skjermen der brukere på siden skal kunne registrere seg, og hvis dere drar musen over her, vil dere se at det er tekst på siden, men den er hvit.
    Er det noen av dere som vet hvilken fil jeg må endre på for endre denne teksten til svart?

    Samtidig ser dere en link på bildet som er der.. Det er vel ikke noen som vet hvor jeg kan endre den linken?
     
  2. Ståle Medlem

    Innlegg:
    1.248
    I css fila? Ser du i kildekoden så ser du hvilke klasser som må forandres på.
     
  3. Gomlers Member

    Innlegg:
    624
    Hvis du ser i kildekoden så står det blant annet:
    <p class="message register">Registrer deg for denne siden</p>
    p class="message register" er den css klassen som html koden din leter etter for å definere
    utseendet på den paragrafen... for å forklare det noe merkelig, men forhåpentligvis folkelig :)

    Du må endre den fila som ligger her:
    http://www.googledetforfaen.com/blog/wp-admin/wp-admin.css

    Putt den inn i et program som f.eks. textpad, og så søker du etter frasen "#login p.message".

    Når du finner #login p.message.... så gå til den øverste linja mellom { og }, så skriver du på den linjen noe sånt som: "color: #000000;"

    trykk ctrl + s (Save), legg den ut, og vips, så skal du forhåpentligvis ha svart tekst på denne..

    (svart = #000000 - i hexadecimal)
    (hvit = #FFFFFF - i hexadecimal)

    Håper dette hjalp noe, og håper for guds skyld det er riktig. Jeg har ikke sjekka, men det kan iallefall se sånn ut. Antakelig så er default satt til hvit ett eller annet sted, for p'n din har ikke fått definert noen farge på teksten enda...
     
  4. Mr Vest

    Mr Vest Sjefen over alle sjefer!

    Innlegg:
    2.079
    Der var en slik bra og fin forklaring jeg håpet på :p Takk.
    Det eneste jeg har gjort er å lete etter noe og endre på, men nå når jeg faktisk fant ut at jeg måtte skrive ny linje med farge, er jeg litt mer på rett vei.
    Linken fikk jeg i boks også.. Av og til begynner jeg og lure på hvorfor jeg i det hele tatt spør, når jeg egentlig kan det...

    Takker for hjelp så langt, men nå har jeg enda ett spørsmål, som sikkert er like dumt som de 2 over.
    Når det gjelder æ, ø og å.. Disse sliter på siden.. Hva kan jeg gjøre for å slippe disse rare tegnene og heller få frem bokstavene?
     
    Sist redigert: 15 Nov 2007
  5. Gomlers Member

    Innlegg:
    624
    Si ifra om du får det til da, ellers så hjelper deg gjerne mer, men det blir nok ikke før i morgen, senga roper høyt nå..

    (ellers så er da andre ganske kompetente medlemmer her ville jeg tro? ) :)
     
  6. Mr Vest

    Mr Vest Sjefen over alle sjefer!

    Innlegg:
    2.079
    Det fungerte helt utmerket :) Nå kan jeg det til en senere anledning :) En liten ting var at det ikke fungerte med
    men med
    .
    Hvorfor aner jeg ikke.. :s Men takker for hjelp :)
     
  7. Gomlers Member

    Innlegg:
    624
    Mulig dette har noe med hvilken browser du kjører. Ofte så virker vel hexadecimaler best i IE?
    Men dette kan nok noen andre bedre enn meg. Har aldri vært noe flink til å huske test-resultater..

    Men ser det virker ja, flott! - Gratulerer!
    Er det ikke deilig når det endelig funker?
     
  8. Mr Vest

    Mr Vest Sjefen over alle sjefer!

    Innlegg:
    2.079
    Ja, hehe. Det er en fin følelse når tingene endelig begynner å dette litt på plass.
    Det beste er vel igrunnen når jeg faktisk får inn i hodet hvordan jeg kan gjøre det til neste gang.
    Her valgte jeg en annen løsning som var og endre bakgrunnsfargen, noe som jeg syns ble litt bedre egentlig...

    Du vet ikke hvordan jeg får æ. ø og å til å vises ordentlig i wordpress vel?
    Det fungerer fint i poster, men de sliter veldig mye i plugins mm..
     
  9. basicus

    basicus SEO Eggspert

    Innlegg:
    487
    æ, ø og å må skrives inn som

    æ = &aelig;
    ø = &oslash;
    å = &aring;

    De store variantene er de samme bortsett fra første bokstav etter &-tegnet som skrives med stor bokstav. Altså Æ = &Aelig;
     
    Tonny Kluften liker dette.
  10. Mr Vest

    Mr Vest Sjefen over alle sjefer!

    Innlegg:
    2.079
    Jeg får det rett og slett ikke til å fungere..
    Det jeg nå har forsøkt, er å legge disse inn i css-fila i riktig klasse, og samtidig har jeg forsøkt å bruke dem i php-fila.
    Det er forumet på siden jeg har forsøkt dem på...

    Når jeg bruker dem i php-filen blir hele forumet på jordet, og når jeg bruker dem i css-fila, blir det rett og slett ingen forandring...

    Det er vel ikke noen andre måter å få dette til på?
     
  11. Gomlers Member

    Innlegg:
    624
    Hallo hallo!
    Ser ut som at du ikke har fått ordna det enda i forhold til hva jeg kan se på meta taggen din:

    Prøv å endre charset=UTF-8" />
    til
    charset=iso-8859-1" />

    Selv om jeg ikke ser hvor problemet ligger i browseren, kan det hende dette løser problemet ditt.

    alle meta-tagger ligger mellom <head> og </head>

    Håper det fungerer.


    PS: Du har IKKE dumme spørsmål... uansett kan du sikkert masse annet kult :D
     

Del denne siden